
The pbcGIS Buildout Calculator is a plugin for Trimble SketchUp that facilitates the design 
and evaluation of massing scenarios .

The plugin adds a group of Buildout Calculator tools to right-click menu to Sketchup.  The 
tools permit you to create  special types of groups for Sites, Buildings and Schemes.  These 
groups have attributes reflecting the amount of gross floor area per use for buildings and 
the amount of parking in lots or in structures.

Sites and buildings are grouped as schemes .  A scheme has parameters reflecting the ratio 
of parking spaces  per GFA for residential and commercial uses.  Multiple schemes might be 
made for each site to evaluate different massing plans or regulatory requirements.  

The Buildout Calculator will create a table summarizing the capacities of selected schemes.  
This table may be saved as an HTML document and opened in a spreadsheet.

The Buildout Calculator Plugin uses a special set of Sketchup Materials that are used to 
distinguish the uses of buildings and site areas.

If you find this plugin saves you time and helps you to do work that you are paid for, 
consider making a donation at www.pbcGIS.com/buildout_calculator.  We are also happy to 
consider requests for new features.  Email paulbcote@gmail.com for more information.
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Install the plugin
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1. Unpack BuildoutCalculator Zip Archive

2. Install Extension with Sketchup 2017 or later 
Extension Manager

3. Add Materials to Buildout Materials to Favorites,
List View
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1. Install Sketchup 2017 or later.  The Free Sketchup Make will be fine.

Unpack the Buildout Calculator Zip Archive
1. Downloaded the zip archive containing the pbcBuildOut Calculator plugin and its 

resources to a folder on your hard drive.  This wil be a folder you want to keep. 
2. Extract the contents of the zip archive to the folder.  (See illustration, above.

Load the Extension
1. From the Window menu in SketchUp, open Extensions Manager.
2. Use the Install button at the lower left of the Extensions Manager and find the 

BuilsoutCalculator…rbz file inxluded in the zip archive.
3. The Builsout Calculator extension should appear in your extensions.  

Install Buildout Materials
1. Open your Sketchup, Material Window.
2. Click the Details button next to the Materials Pulldown and select, Add Collection to

Favorites.
3. You should now see a collection of textures created for the BuildOut Calculator.  
4. Click Details again and choose List View, so you can see the names of the textures.  



Start a Model 
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Currently the Buildout Calculator plugin requires a model that uses units in Feet.  To 
facilitate the design of sites at the correct scale it is helpful to have a groundplan image.  
The easiest way to get one of these is to use File>Geo Location to grab an image of your 
site.  

Alternatively, you bring in any groundplan image and scale it.  This process is described in 
the appendix of this documentation.
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Set Up a Model from GIS
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Flat Reference Image

3D Model

Models created by pbcGIS are more detailed than models captured by Sketchup.  There are 
a few steps you should go through to set up  these models:

1. Go to Window > Preferences > OpenGL and specify Use Maximum Texture Size

2. When you creaate a new scheme, create a new layer for buildings that wil lbe
removed for that scheme.  Move the existing buildings to this layer so you can easily 
turn them off.

3. When modeling your new scheme, turn off al layers except for the reference Image.  
This will allow you to create planar objects without snapping to the terrain.

4. When you want to preview your new scheme, you will need to move the objects up 
to the height of the terrain.  Since the site objects are flat, you may need to move 
them a bit above the elevation of the grouns.
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Sites are the unit of analysis over which development and parking capacity are calculated.   

A site is simply a polygon created with any of the Sketchup draw tools.  

Once you have created the polygon open the Materials window and find the Buildout 
Materials Folder.  It is helpful to change the view of the Materials window to list the details 
for materials so that you can see their names.

Color the site using the Site Default material.

If your site has a parking lot, divide the site polygon and color the parking area with the 
Parking Material.

Now triple-click the site polygon to select all of the connected faces and edges.

Finally Right-Click the selected geometry and choose Create Site Group for the Buildout 
Plugin tools.  
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Create a Site Group
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Create Polygon for Site

Apply Materials for 
Parking and Default 
Site Background

Select All, Right-Click 
And choose 
“Create Site Group” 



Inspect Site Attributes
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Build-Out Calculator
Site Object

Expose Dynamic 
Components toolbar. 
View>Toolbars… 

The Buildout Calculator plugin uses a Sketchup functionality known as Dynamic 
Components.  Dynamic Components let you attach attributes to groups or components 
within SketchUp.  This makes Sketchup a little like GIS.

To inspect the attributes of your new site group, expose the Dynamic Components toolbar.  
In Sketchup 2013 this is accomplished by going to View>Toolbars and checking on the 
Dynamic Components toolbar.

Then select your site and click the Component Options button.  This is usually the middle 
button in the Dynamic Components toolbar. 
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Model a Building
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Model building parts 
as simple extrusions.

Apply materials to 
indicate use.  

Select All, Right-Click 
And choose 
“Create Building Group” 

Gridded materials 
Indicate stories.  

Buildings can be any sort of shape, but it is easiest to create them as polygons that are 
extruded with the Push-Pull tool.  

You can color buildings with any textures that you like except for the roof.  It is important to 
color the roofs of buildings with one of the roof materials in the Buildout Materials group.  
This is how the building area is calculated.  

I recommend that you use the Residential, Retail, Commercial ,Institutional, Industrial 
materials to color the vertical faces of buildings.  The Parking Wall material is handy for 
indicating the faces of parking structures.  

If you have different parts of a building that have different uses, such as Ground-floor retail, 
as pictured above, you do not need to make this a separate extrusion, you can simply 
divide the faces of your building and color them. 

Now triple click the building to select all connected edges and faces , right-click the 
selected geometry and choose Create Building Group from the Buildout Calculator tools. 
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Update Building Attributes
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Choose roof material.

Fill in attributes for  
usage by stories.

Gross Stories and GFA 
updated automatically.

Expose Dynamic 
Components toolbar. 
Expose attributes for 
building. 

Use the Component Options tool from the Dynamic Components  toolbar to bring up the 
Options inspector for your new building group.

Pull down the Use Class menu and pick the use-class designated by the roof material you  
assigned to the roof of your building.  The area of all the polygons in your building group 
colored by this material will be used to calculate the floor-plate are of your building.  For 
this reason it is important that you have only used this texture on the roof of the building.  
If you accidentally assigned the roof texture to other parts of the building, this can create 
errors in your GFA calculations.

The Buildout Calculator automatically calculates a Gross Floor Area for the building based 
on the number of stories (estimated form the building height.    This estimate assumes that 
the building is all one use.  

The GFA figures that the calculator uses in its summaries are calculated according the 
numbers of floors for each use that you enter into the fields  provided in the fields on the 
bottom half of the Building Options inspector.    It is OK to enter fractional floors here.

After updating these values, click  the apply button.  

If you change the geometry of the building it is sometimes necessary to click it with the 
Redraw button from the Dynamic Components Toolbar to get the areas to recalculate.
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Create a Scheme
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Add more buildings.

Select buildings and site

Right-click and choose:
Create Scheme Group.

If you have complicated buildings having parts of different shapes it is often easier to model 
the different pieces as independent building groups. 

When  you have a site group and a building group, you can select them all, right-click and 
choose Make Scheme Group  from the Buildout Calculator tools.  
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Name and Adjust Scheme
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Name Scheme and edit
Default parking 
requirements if necessary.

Use the Component Options tool form the Dynamic Components toolbar to reveal the 
scheme options.

You should give each scheme a unique name.   Because the Scheme s are sorted 
alphabetically in the Buildout Report, it is useful to begin the scheme name with the  
identifier of the site.  This will make it easier to compare the reports from different 
scenarios,.

The Scheme Options Inspector reveals the default  ratios of parking area to floor area in 
your scheme.  This is broken down by Residential area and Commercial area.  You can also 
set the square feet of area required for each parking space according to the use-type.  The 
Retail Parking cushion is the  GFA that is permitted for retail before a parking requirement 
kicks in. 
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Tabulate Schemes

07/15/2015Paul Cote 11

Create another scheme

Use the sketchup
Outliner window to
Select and manage 
scheme groups 

A table will appear.

Right-click and choose:
“Tabulate Schemes”

If you have one or more schemes , you can select them, right-click  and choose Tabulate 
Schemes from the Buildout Calculator Tools menu.  

A table  will appear in a pop-up window.  
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Examine & Export Schemes Table
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Save report as an 
HTML file.

Open table in excel.

Inspect this table and make sure it makes sense.  

If there are schemes that seem to have too little GFA or too little parking, you should go 
through the buildings and make sure that you have chosen their use-class appropriate for 
their roof material and set their Floor-Use attributes appropriately.

After inspecting this table you can dismiss it by simply closing the pop-up window .

The schemes report can be opened in Excel.   The simplest way is by selecting  the 
contents and then copy-paste them into a blank Excel worksheet.  Or you can use the 
button at the bottom-right to save the table to a file on your hard drive.  This file will be an 
HTML document that can be opened in Excel.  Opening the HTML version of the report in 
Excel preserves the formatting of the table.  
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Control Visibility of Schemes
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If you want to create and evaluate  altrnative design schemes for the same place,, then you 
can use the Sketchup Outliner Window to find the scheme.  Right-click on the scheme and 
choose Hide. 
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